ACER\_FG\_install\_note

ACER_FG_install_note

ACER_FG_install_note #先使用光碟安裝Ubuntu5.1.0 apt-get install edubuntu-artwork 把原來的Ubuntu 換成教育版的theme #解決音效問題 ref:fortuneland_note.txt 1. sound card 搞定了 F5 C28這一款,用的是Realtek ALC880晶片,在Ubuntu Breezy中,自己再編alsa kernel 不能用來的alsa 1.0.9a,直接用Ubuntu dapper 主要參考這個 https://wiki.ubuntu.com/HdaIntelSoundHowto?highlight=%28hdaintel%29 但是他講說在breezy中應該不用改,不對。 1. source list中 deb http://linux.nchc.org.tw/ubuntu dapper main restricted universe 2. apt-get update apt-get install alsa-source 3. apt-get install linux-headers-2.6.12-10-686 apt-get install kernel-package ## installs make-kpkg apt-get install ncurses-dev ## I am not sure if this is really needed \$ less /usr/share/doc/alsa-source/README.Debian dpkg-reconfigure alsa-source ## choose azx as driver or choose all apt-get install fakeroot cd /usr/src tar jxf alsa-driver.tar.bz2 cd linux-headers-2.6.12-10-686 make-kpkg --rootcmd=fakeroot --append-to-version=-10-686 modules-image cd .. dpkg -i alsa-modules-2.6.10-5-686_1.0.8-4ubuntu4+10.00.Custom_i386.deb vi /etc/modprobe.d/sound options snd device_mode=0666 alias snd-card-0 snd-hda-intel alias sound-slot-0 snd-hda-intel options snd-hda-intel model=6stack position_fix=1 \^\^\^\^\^\^\^\^\^\^\^\^這個是關鍵,然後到gnome的聲音控制程式中,把front-audio開啟,靠,有六個聲道 ubuntu:/usr/src/modules/alsa-driver/alsa-kernel/Documentation/ALSA-Configuration.txt 然後似乎要在 /etc/modules中寫snd-hda-intel,要不然不會開機時自動起來! -------- ... snd-hda-intel #vlc and cdrom check!! 看能不能播放vcd與dvd 以vlc播放vcd聲音會頓;但是xine不會! compile VLC 先準備好工具 a. sudo apt-get install g++ gcc make automake 看看說明 sudo ./configure --help 檢查一下有缺什麼東西先補一補 不需要用avahi!會有問題 sudo ./configure |grep warn b. 修改source.list deb http://download.videolan.org/pub/videolan/debian sid main deb-src http://download.videolan.org/pub/videolan/debian sid main c. 安裝需要的套件 apt-get update sudo apt-get install libmpeg2-4-dev libfaad2-dev libmad0-dev libavcodec-dev libavformat-dev lame faac faad nasm libwxgtk2.6-dev mozilla-dev libx11-dev xlibs-dev libpostproc-dev libcdio-dev libvcdinfo-dev libhal-dev libcddb-dev libdvdread3-dev libdvdcss2-dev libdvdnav-dev libdvb-dev libdvbpsi3-dev libgnomevfs2-dev libgtk2.0-dev 開始configure sudo ./configure --enable-dvb --enable-dvdread --enable-v4l --enable-pvr --enable-cddax --enable-vcdx --enable-faad --enable-real --enable-realrtsp --enable-flac --enable-esd --enable-arts --enable-mozilla --enable-faac --enable-debug --enable-wxwidgets checkinstall 產生vlc-0.8.4a_0.8.4a-1_i386.deb 還原一開始的image 處理好音效候裝vlc只要作前面a. b. c. 三步驟 再dpkg -i vlc-0.8.4a_0.8.4a-1_i386.deb 即可使用vlc 播放vcd dvd 畫面與聲音不會頓

#gnome-volume-manager 修改預設啟動方式 當vcd光碟放入時 會自動跑totem %d 但我希望改成vlc /dev/hda 執行 gnome-volume-manager 有圖形介面可以控制 如果要改系統預設的value 要改/usr/share/gconf/schemas/gnome-volume-manager.schemas 把"totem %d" replace to"vlc /dev/hda" dpjg-reconfig gnome-volume-manager /etc/init.d/gdm restart 當我放入光碟之後vlc就在play了 #更新 把backport, security 打開! sudo apt-get update; sudo apt-get upgrade #中文輸入 gcin 1. apt-get install im-switch 2. deb http://www.calno.com unstable main 然後 apt-get update apt-get install gcin 如果gcin沒有變成預設的,這樣改 im-switch -z zh_TW -s gcin #skype sudo apt-get install fakeroot alien fakeroot alien --to-tgz skype_1.2.0.18-1_i386.deb sudo apt-get install libqt3-mt libstdc++5 fakeroot alien --to-deb skype-1.2.0.18.tgz sudo dpkg -i skype_1.2.0.18-2_all.deb 調整skype中文字型 sudo apt-get install qt3-qtconfig sudo qtconfig 就可以改自己想要的字型! PS:看電影或視聽音樂不可以使用skype 會有音效裝置錯誤的訊息 #將光碟機放入vcd時totem會自己跑出來的功能關掉 執行 gnome-volume-properties or 系統->偏好設定->抽取是儲存裝置與媒體 裡頭把 "多媒體" 當視訊光碟放入時立即播放 給關掉 #使用floppy 不知道為什麼hotplug 不處理我的軟碟 所以在/etc/modules 加入 floppy 讓使用者可以半自動使用floppy #XMMS 亂碼 其實可以改用BMP播放 因為差不多 如過要解決亂碼 可以這樣弄\~\~ 1.先新增字型 參考@ Defoma(用於 XTT、Truetype、PS 字型。) 2.cp /etc/gtkrc.utf8 /etc/gtkrc.zh_TW.utf8 3.修改/etc/gtkrc.zh_TW.utf8 ru8 加入新宋體 style "default-text" { fontset = "-arphic-ar pl new sung-medium-*-*-120-*-*-c-*big5-0,\\\\\\\\\\\\\\\ -*-arial-medium-r-normal--*-120-*-*-*-*-iso10646-1,\\\\\\\\\\\\\\\ -*-helvetica-medium-r-normal--*-120-*-*-*-*-*-*" } class "GtkWidget" style "default-text" @ Defoma(用於 XTT、Truetype、PS 字型。) * 把字型檔複製到 /usr/share/fonts/truetype 下,(最好自行新建立子目錄以利分類)。 * 注意一下新的目錄(建議為 755)及字型檔的權限(建議為 644)。 * 使用 defoma-hints --no-question truetype FontFileName > FontName.hints 建立字型資訊檔。 例fireflysung.ttf: apt-get install libft-perl defoma-hints --no-question truetype /usr/share/fonts/truetype/fireflysung.ttf > /etc/defoma/hints/ttf-fireflysung.hints * 如果有需要,請自行修改 FontName.hints 的內容以符合您的需求。 或者,在執行 defoma-hints 時不要加上 --no-question 參數,它會出現設定介面來讓我們自訂 FontName.hints 的內容。 例: category truetype begin /usr/share/fonts/truetype/hangwang/wt024.ttf Family = HanWangFangSongMedium FontName = HanWangFangSongMedium-Regular Encoding = Unicode Location = English Chinese-Taiwan Charset = ISO10646-1 BIG5 CNS11643-1 CNS11643-2 CNS11643-3 CNS11643-4 CNS11643-5 CNS11643-6 CNS11643-7 ISO8859-1 UniCharset = BIG5 ISO8859-1 GeneralFamily = Roman Weight = Medium Width = Variable Shape = Normal Upright Foundry = HanWang Priority = 20 TTCap = halfwidth-bw=0.5 italic-angle=0.167 no-roblique no-oblique no-ritalic end * 如果發現字形的中、英文字型竟然同寬,則在 FontName.hints 裡加入這麼一行來修正這個問題: TTCap = halfwidth-bw=0.5 italic-angle=0.167 no-roblique no-oblique no-ritalic * 使用 defoma-font -vt reregister-all /PatchToFile/FontName.hints 來註冊字型。 例: defoma-font -vt reregister-all /etc/defoma/hints/ttf-HanWang-FangSong.hints * 重新啟動 X,或是執行 xset fp rehash,即可讓新增的字型生效。 #flash player sudo apt-get install flashplugin-nonfree flashplayer-mozilla #microphone Blake告知可以這樣測試 apt-get install sox rec -d /dev/dsp a.wav play -d /dev/dsp a.wav Acer F5這台要這樣設定 把耳麥插到主機的前方兩個孔,分別是Front的喇叭(綠)和Front Micro(紅) 開啟音量控制偏好設定,勾選這些 PCM, Front, Capture, Input Source就好了。 其他的啥capture 1/2, input source 1/2都不要。選好之後,出現的音量控制會有3個分類 a. 播放,這裡只出現PCM和Front b. 錄音,這裡只出現capture c. 選項,這裡只出現Input source,這個地方要設定至少有一個為Front Mic. # win32 codec deb ftp://cipherfunk.org/pub/packages/ubuntu/ breezy main --- then apt-get update; apt-get install w32codecs #pdf 安裝acrobat官方提供的版本 http://www.chinese-t.adobe.com/products/acrobat/readermain.html 不要下載rpm 最好改成tar.gz 對話安裝 安裝於/usr/local/Abobe/ PS 有嘗試過fakeroot alien -k --to-deb AdobeReader_cht.rpm 安裝deb後無法執行acroread 或是 plugin有問題! #mpage 可以使用指令將ps檔 n[1, 2, 4, 8]頁印成一面! mpage -2 xxx.ps //兩頁印成一面 PS:但要使用者先印成檔案 在下指令 有點麻煩\~\~ #安裝DVD DeCSS /usr/share/doc/libdvdread3/examples/install-css.sh Ref: /usr/share/doc/libdvdread3/README.Debian #要安裝 language-support-zh 這樣gdm/gnome中所有的顯示才會幾乎是中文。 使用aptitude選task中的部分安裝起來並沒有安裝這個,再選一下這個他會自己安裝 laguage-support-gnome-zh, mozilla..-zh... openoffice...-zh等等 #裝stardict sudo apt-get install stardict stardict-common 然後下載字典 http://stardict.sourceforge.net/Dictionaries_zh_TW.php http://prdownloads.sourceforge.net/stardict/stardict-cdict-big5-2.4.2-1.noarch.rpm?download http://prdownloads.sourceforge.net/stardict/stardict-oxford-big5-2.4.2-1.noarch.rpm?download 等等 然後用 fakeroot alien -k --to-deb stardict-cdict-big5-2.4.2-1.noarch.rpm fakeroot alien -k --to-deb stardict-oxford-big5-2.4.2-1.noarch.rpm 等轉換後,dpkg -i sudo dpkg -i stardict-cdict-big5_2.4.2-1_all.deb sudo dpkg -i stardict-oxford-big5_2.4.2-1_all.deb #如何裝jre 1.5 http://www.linuxhall.org/modules.php?name=News&file=article&sid=417 Ubuntu 5.10 用上了 GCJ 作為預設的 Java VM, 但 GCJ 的核心只是 1.4.2 . 因此一些須要 Java 1.5 VM 的程式 (如: Azureus) 便未能運作. 而在 Ubuntu wiki 中, 找到了解決的方法... 1. 要在系統中加入 "universe" 和 "multiverse" repositories. 詳情請參閱以下網址: https://wiki.ubuntu.com/AddingRepositoriesHowto 2. 到 http://java.sun.com/j2se/1.5.0/download.jsp 中下載 "JDK 5.0", 只可以下載 "Linux self-extracting file" (jdk-1_5_0_05-linux-i586.bin) (不可以用RPM version) 3. 安裝 fakeroot, java-package 及 java-common 套件 指令: sudo apt-get install fakeroot java-package java-common 4. 製作 JDK 1.5 套件 指令: fakeroot make-jpkg jdk-1_5_0_05-linux-i586.bin 5. 安裝 JDK 1.5 套件 指令: sudo dpkg -i sun-j2dk1.5_1.5.0+update05_i386.deb 6. 選擇 Sun JDK 為預設 Java VM 指令: sudo update-alternatives --config java 原文網址為: https://wiki.ubuntu.com/RestrictedFormats

# FF and JVM

  • 安裝 java runtime environment
  • 你可以在 java 的安裝目錄下 ../plugin/i386/ns610-gcc32/ 找到 .so 檔
  • 在 \~/.mozilla/plugins/ 目錄裡做一個符號連結到 libjavaplugin_oji.so,不可以直接複製。

cd \~/.mozilla/plugins/ ln -s /usr/java/jre1.5.0_04/plugin/i386/ns7-gcc29/libjavaplugin_oji.so

#realplayer 從官方下載安裝程式安裝 http://www.real.com/linux #安裝openoffice 2.0.2 firefly版: 1. Ceasar已經用alien把firefly的2.0.2版轉成deb http://openoffice.nchc.org.tw/download/debian/2.0.2/ 2. download那三個.deb檔,然後 sudo dpkg -i openoffice.org_2.0.2-3_i386.deb sudo dpkg -i openoffice.org-i18n-zh-tw_2.0.2-2_all.deb sudo dpkg -i openoffice.org-psprint-driver_2.0.2-2_all.deb 3. mv /usr/lib/openoffice2 /usr/lib/openoffice2.old ln -fs /opt/openoffice.org2.0/ openoffice2 4. 不想看到啟動時候的splash的話: ref: http://www.newsforge.com/software/03/04/22/1931223.shtml?tid=51 改/opt/openoffice.org2.0/program/sofficerc (要chmod u+w sofficerc) 把Logo=1改成Logo=0 ps:我有兩個openoffice的menu , openoffice2是ubuntu預設安裝的版本 openoffice2.0firefly版 由於menu 是透過 smeg去改的 所以我直接把/usr/share/applications/ 裏面中openoffice2的項目暫時搬到/root/* mv /usr/share/applications/ooo2* /root mv /usr/share/applications/template.desktop /root 如此當新增user時menu就不會錯誤 #驗證!! 檢驗電腦是否可以跑Linux 基本辦公可以使用 鍵盤 是否可以使用鍵盤 開機可直接使用數字鍵 (numlockx) 滑鼠 是否可以使用滑鼠 影像卡 3D 可不可以進去圖形介面1024x768 or better 播放影片不會停滯 音效卡 能否清晰的聽到聲音 能用麥克風 網路卡 網路有通 PXE support wol 硬碟機 有抓到硬碟 以hdparm測速,開啟dma 光碟機 讀取、使用、播放 data-cd CD VCD data-dvd DVD 播放影片不會停滯 軟碟機 可以讀取floppy USB 隨身碟的使用 @以自動/半自動 掛載 usb cdrom floppy //不下指令

convert from Thomas blog post id 19 old convert log: ./164600/tag%3E2006%2010%20linux)

@2006 @10 @linux

Comments